Московское отделение
Пензенского научно-исследовательского
электротехнического института
Средства криптографической защиты информации

Версия для печати версия для печати
Обновление для «СКЗИ Верба-OW» версии 6.1.2 для работы с ключевыми носителями eToken PRO с операционной системой CardOS 4.2 и для обеспечения совместимости с драйвером «PKI Client».
 
Обновление предназначено для обеспечения возможности работы СКЗИ с версией ключевых носителей «eToken PRO» на которых установлена операционная система «CardOS v.4.2», а также для обеспечения совместимости с драйвером «PKI Client».
 
Как определить, что вам необходимо это обновление
 
Вам необходимо это обновление, если:
1. Вы используете СКЗИ «Верба-OW» версии 6.1.2, и
2. Вы используете в качестве ключевого носителя устройство «eToken PRO», и
3. При попытке обращения к ключам выводится сообщение об ошибке (например, «Устройство не готово» или «Невозможно загрузить ключ»)
Вероятно, проблема вызвана использованием в устройстве «eToken PRO» новой версии операционной системы «CardOS v.4.2» или использованием драйвера «PKI Client»
В этом случае установка обновления может решить проблему.
 
Для определения версии ключевого носителя «eToken PRO» необходимо, чтобы на компьютере был установлен набор драйверов «eToken RTE» или «PKI Client». Набор драйверов eToken и эксплуатационную документацию по eToken можно установить с прилагаемого к устройству «eToken PRO» диска с драйверами или скачать по следующему адресу: http://www.aladdin-rd.ru/support/download/463/
Драйвер «eToken RTE» должен иметь версию не ниже 3.66.
Драйвер «PKI Client» должен иметь версию не ниже 4.55.
 
В состав набора драйверов входит утилита администрирования eToken. Ярлык утилиты - "Пуск\Все программы\eToken\eToken Properties". Версия операционной системы eToken PRO отображается в окне свойств eToken, в строке "CARD\OS version".
 
Если CARD\OS version ниже чем CardOS V4.2 и используется драйвер «eToken RTE»:
Обновление не требуется.
 
Если CARD\OS version больше или равна CardOS V4.2 или используется драйвер «PKI Client»
Необходимо:
1. Установить набор драйверов «eToken RTE» версии не ниже 3.66 или «PKI Client» версии не ниже 4.55
2. (Если СКЗИ «Верба-OW» ещё не установлено) Установить СКЗИ с поддержкой ключевых носителей «eToken» согласно инструкции по установке.
3. Установить обновлениe (patch_etOS42). Обновление доступно для свободной загрузки с сайта МО ПНИЭИ www.security.ru (ссылка на файл внизу этой страницы).
 
Установка обновления должна производиться пользователем с правами локального администратора компьютера. Во время обновления не должны быть запущены программы, использующие СКЗИ «Верба-OW».
Для запуска обновления распакуйте файл patch_etOS42.zip, проверьте целостность обновления (см.ниже) и запустите программный модуль patch_etOS42.exe.
 
При запуске программа обновления проверит возможность установки обновления и, при согласии пользователя, произведет установку. По окончании установки будет выдано сообщение "Обновление модулей поддержки «eToken» произведено успешно". Если установка не удалась - проверьте соблюдение всех условий, указанных выше и повторите установку.
Перезагрузка компьютера после установки обновления не требуется. Установленное обновление не может быть отменено.
 
Информация для системных администраторов:
 
 
Обновление заменяет следующие файлы:
1. файл etsdk.dll в системном каталоге ОС Windows.
Версия файла содержится в ресурсе "VersionInfo", поле "FileVersion".
Файл обновления имеет номер версии "1, 0, 0, 47" (размер файла 335872 байта).
2. файл etok.dll в подкаталоге "reader" системного каталога ОС Windows.
Версия файла содержится в ресурсе "VersionInfo", поле "FileVersion".
Файл обновления имеет номер версии "1, 0, 1, 1" (размер файла 24576 байт).
 
  Проверка целостности программного модуля обновления.
 
 
 
В архиве patch_etOS42.zip содержится исполняемый модуль обновления - patch_etOS42.exe и файл верификации исполняемого модуля - patch_OS42.vrf. Файл верификации предназначен для автоматической проверки модуля обновления в АРМе контроля целостности (Check.exe) версии 2.0.6 и выше.
 
Для проверки целостности исполняемого модуля распакуйте архив, запустите АРМ контроля целостности ("Пуск\Все программы\СКЗИ Верба-OW\АРМ контроля целостности"), откройте файл верификации patch_etOS42.vrf и выполните проверку.
Если проверка прошла успешно (см. как пример, результат успешной проверки) можно запускать программный модуль patch_etOS42.exe.
 
Если у Вас установлен АРМ контроля целостности версий меньше чем 2.0.6, создайте с помощью АРМа список верификации с файлом patch_etOS42.exe и рассчитайте значение хэш-функции файла patch_etOS42.exe.
 
Значение хэш-функции должно быть следующим:
 
A2 27 3F 81 1E 8E 76 C4 3F 70 B9 A1 0D E3 95 91
F1 8D E1 64 49 03 0D 49 10 67 9C A9 AE EF 53 2E
 
Файл для загрузки:
 
 
  patch_etOS42.zip (168 килобайт) обновление СКЗИ «Верба-ОW» для работы с ключевыми носителями eToken PRO CardOS 4.2 и обеспечения совместимости с драйвером «PKI Client».




star star
© «МО ПНИЭИ» - Средства Криптографической Защиты Информации, 15 декабря 2018 г. 
star